Contrato permanece como "Pronto para faturar" após faturamento

Falha

O contrato permanece com o status Pronto para faturar no portal ASM, mesmo após o faturamento já ter sido realizado.

Causa

O problema ocorre quando o portal ASM tenta enviar um faturamento com valor R$ 0,00 ao ERP, e este não aceita pedidos zerados.

Como a integração é rejeitada, o envio não é concluído, o processo de faturamento fica incompleto e, consequentemente, o status do contrato não é atualizado para Faturado no portal ASM.

Solução

  • Correção definitiva (recomendada): ajuste o ERP para permitir o recebimento de pedidos com valor R$ 0,00 provenientes da integração.

  • Correção imediata (alternativa): caso não seja possível ajustar o ERP, realize o faturamento manual das unidades com valor zerado, marcando a opção Não enviar para ERP, para liberar o status global do contrato.
    Esta alternativa deve ser utilizada como exceção, pois impacta o fluxo de faturamento.

  • Preventiva (alternativa): caso não seja possível ajustar o ERP, para evitar a recorrência da falha, desvincule a unidade de faturamento dos equipamentos que possuem o mesmo cliente (CNPJ) do contrato principal, na aba Equipamentos do contrato.
    Esta alternativa deve ser utilizada como exceção, pois pode impactar outros recursos do sistema.