Error code 8003

Failure

The log from the NDD - Printer Monitor USB or NDD - Thermal Monitor USB services recorded error code 8003 (LoadPrinterDetailsException).

Cause

  • Cause 1: the service was unable to correctly capture the device's information.

  • Cause 2: the Epson printer connected via USB is using a generic driver.

Solution

Cause 1

Restart the device and reconnect it to the computer on which the DCA and Cloud Connector agent is installed.

Then make sure that the device is not in configuration mode. In some cases, the device may not transmit information when it is in this mode.

Finally, check that all the device's doors and/or covers are correctly closed. Open doors or poorly closed lids can affect communication and information collection.

Cause 2

Install the official EpsonNet SDK driver provided by the manufacturer, and verify that all the Agent installation prerequisites have been met.

If the failure is not resolved using the solutions above, we recommend opening a support ticket for assistance in resolving the problem.