Falha
Após instalar ou atualizar o DCA and Cloud Connector, o agente continua exibindo uma versão anterior ou os serviços vinculados não são atualizados corretamente.
Também pode ocorrer de o DCA and Cloud Connector aparecer online, enquanto os serviços associados permanecem em versões antigas, não são exibidos corretamente ou apresentam comportamento inesperado.
Causa
O problema pode ser causado pela existência de resquícios da instalação anterior, por falhas durante o processo de atualização ou por inconsistência nos arquivos locais do NDD Orbix.
Quando há uma instalação antiga já registrada no computador, o novo serviço pode não se comunicar corretamente com os dados locais existentes. Também pode ocorrer timeout durante a atualização dos serviços, mantendo componentes em versões anteriores.
Contexto técnico relacionado:
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Pode existir comunicação de uma instalação antiga ainda registrada.
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A pasta Workfolder pode conter dados residuais.
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A atualização pode falhar por timeout.
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O portal pode exibir o DCA and Cloud Connector online, mas ainda com versão antiga.
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O DCA and Cloud Connector é o serviço responsável por instalar e atualizar os demais serviços.
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A atualização via portal NDD Orbix depende de comunicação com a rede e download dos pacotes necessários.
Solução
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No portal NDD Orbix, verifique a versão do DCA and Cloud Connector exibida para o computador
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No computador, verifique a versão instalada
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Verifique se o instalador utilizado é a versão mais recente disponível
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Caso esteja utilizando uma versão antiga do instalador, baixe a versão mais recente, conforme instruído em Instalar o agente DCA and Cloud Connector no Windows
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Execute o instalador mais recente como administrador
Observação
Em uma atualização convencional, instale a nova versão sobre a já existente. Não desinstale a versão anterior, exceto quando houver orientação técnica específica.
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Aguarde a conclusão da instalação
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Reinicie o serviço NDD - DCA and Cloud Connector
Informação
Após a reinicialização do serviço NDD - DCA and Cloud Connector, os demais serviços serão instalados ou atualizados automaticamente conforme a configuração recebida do portal.
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Verifique se o agente e os serviços dependentes foram atualizados corretamente
Se os serviços continuarem desatualizados ou inconsistentes:
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Acesse o computador com permissão administrativa
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Pare todos os serviços do NDD Orbix no Windows
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Acesse o diretório C:\NDD TECH
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Exclua a pasta Workfolder
Aviso
A pasta Workfolder deve ser removida somente com todos os serviços do NDD Orbix parados.
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Inicie somente o serviço NDD - DCA and Cloud Connector
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Aguarde o agente estabelecer nova comunicação com o portal
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Solicite a atualização dos serviços pelo portal NDD Orbix, conforme instruído em Atualizar a versão do agente DCA and Cloud Connector, do Gateway Connector ou dos serviços pelo portal
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Valide se o DCA and Cloud Connector e os demais serviços foram atualizados
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Execute novamente a busca de impressoras, se necessário
Se o problema persistir, colete os logs de instalação e atualização.
Informações adicionais:
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Esse procedimento é indicado quando há evidência de instalação anterior, falha de comunicação entre serviço novo e dados antigos ou timeout de atualização.
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A instalação com versão antiga pode aumentar o tempo de implantação, pois exige atualização posterior dos serviços.
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Não remova manualmente arquivos ou diretórios além dos indicados neste procedimento, pois isso pode causar novas inconsistências na instalação.
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Quando a instalação for realizada por ferramenta de distribuição, como SCCM, os logs da ferramenta também devem ser analisados.