Agente DCA and Cloud Connector não se comunica corretamente com o portal NDD Orbix

Falha

O DCA and Cloud Connector está instalado no computador, mas não consegue se comunicar corretamente com o portal NDD Orbix.

Também pode ocorrer falha ao iniciar o serviço, ausência de comunicação do computador no portal, falha na identificação do equipamento ou impossibilidade de validar corretamente as informações do sistema operacional.

Causa

O repositório do Windows está corrompido.

Quando o repositório do Windows apresenta inconsistência, o serviço do DCA and Cloud Connector pode não conseguir obter corretamente as informações do sistema operacional necessárias para comunicação com o portal NDD Orbix.

A validação pode ser feita por meio da consulta do UUID do equipamento. Quando o repositório está íntegro, o comando deve retornar um GUID válido.

Contexto técnico relacionado:

  • O DCA and Cloud Connector pode estar instalado, mas sem comunicação com o portal.

  • O serviço pode não retornar corretamente informações do Windows.

  • A comunicação pode falhar mesmo com portas e rede liberadas.

  • A falha está relacionada ao repositório do Windows.

  • O procedimento recomendado é restaurar o winmgmt.

  • Se existirem serviços dependentes do winmgmt em execução, será necessário pará-los antes de executar a restauração.

Solução

  1. Acesse o servidor ou computador com usuário administrador

  2. Abra os Serviços do Windows como administrador (Win + R → digite services.msc OK)

  3. Localize o serviço NDD - DCA and Cloud Connector

  4. Pare o serviço NDD - DCA and Cloud Connector

  5. Abra o Windows PowerShell como administrador

  6. Execute o comando winmgmt /resetrepository para restaurar o repositório do Windows

Se não retornar erro:

  1. Execute o comando (Get-CimInstance -ClassName Win32_ComputerSystemProduct).UUID para validar se o Windows retorna o GUID do equipamento

  2. Caso o GUID seja retornado, inicie novamente o serviço NDD - DCA and Cloud Connector no Windows

  3. No portal NDD Orbix, verifique se o serviço NDD - DCA and Cloud Connector é exibido e está com o Status como Online, conforme instruído em Visualizar informações dos serviços, e valide se o computador voltou a comunicar corretamente

Se retornar a mensagem “Impossível executar, pois há serviços ou processos rodando que dependem dele”:

  1. Execute o comando Get-Service -Name winmgmt | Select-Object -ExpandProperty DependentServices para listar os serviços que estão rodando e dependem diretamente do winmgmt

  2. Pare todos os serviços com o status Running:

    1. Execute o comando sc.exe stop <serviceName>, substituindo <serviceName> pelo nome do serviço

💡

Exemplo

sc.exe stop vmns

  1. Após parar todos os serviços dependentes em execução, execute o comando winmgmt /resetrepository

  2. Se o comando não retornar erro, execute o comando (Get-CimInstance -ClassName Win32_ComputerSystemProduct).UUID para validar se o Windows retorna o GUID do equipamento

  3. Caso o GUID seja retornado, inicie novamente o serviço NDD - DCA and Cloud Connector no Windows

  4. No portal NDD Orbix, verifique se o serviço NDD - DCA and Cloud Connector é exibido e está com o Status como Online, conforme instruído em Visualizar informações dos serviços, e valide se o computador voltou a comunicar corretamente

  5. Reinicie os serviços dependentes que foram parados no passo 2


Se o agente DCA and Cloud Connector ainda não comunicar:

  1. Reinicie o computador

  2. Após a reinicialização, valide novamente a comunicação do DCA and Cloud Connector no portal NDD Orbix

Se o problema persistir:

  1. Colete os logs do serviço, os eventos do Windows e as evidências da execução dos comandos

Informações adicionais:

  • Execute todos os comandos com permissão administrativa.

  • Antes de restaurar o repositório, pare o DCA and Cloud Connector por precaução.

  • O comando winmgmt /resetrepository pode falhar quando há serviços dependentes do winmgmt em execução.

  • Somente serviços dependentes com status Running precisam ser parados para liberar a restauração.

  • Após a restauração, os serviços parados manualmente devem ser iniciados novamente.

  • Em servidores, execute o procedimento em janela de manutenção.

  • O retorno de um GUID no comando de validação indica que a consulta ao repositório do Windows foi restabelecida.

  • Esse procedimento deve ser aplicado quando houver indício de falha local no repositório do Windows, antes de tratar o caso como bloqueio de comunicação com o portal.

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