Falla
Tras instalar DCA and Cloud Connector, el agente no aparece en el portal NDD Orbix.
Causa
En la carpeta de instalación del agente (C:\NDD TECH\Workfolder\logs), se ha generado un archivo .txt con uno de los errores. Cada error está asociado a una causa específica.
Causa 1: falla al insertar la clave del cliente
[ERR] Agent authentication failed
[{"ErrorCode":null,"ErrorMessage":"{\"ErrorCode\":500,\"ErrorMessage\":
\"Value cannot be null. (Parameter 'request')\"}","PropertyName":null,"$Type":"ApiError"}]
Esta falla se produce cuando la clave del cliente se ha introducido incorrectamente durante la instalación del agente.
Causa 2: falla de clase no válida
[ERR] Failed to get machine ID Microsoft.Management.Infrastructure.CimException:
Classe inválida at
Microsoft.Management.Infrastructure.Internal.Operations.CimSyncEnumeratorBase`1
.MoveNext() at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1
source, Boolean& found) at
System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable`1 source) at
NDPAgents.SDK.Common.Helpers.EnviromentSettingsHelper.WindowsEnviromentS
ettingsHelper.GetMachineId() 2025-07-15 17:08:00.375 -03:00 [ERR] Failed to get
machine ID Microsoft.Management.Infrastructure.CimException: Classe inválida
Esta falla está relacionada con el servicio WMI de Windows, utilizado por DCA and Cloud Connector para recopilar información del sistema y de los dispositivos.
Causa 3: falla de autenticación del agente
[ERR] Failed to get ram memory from the machine through the
Win32_ComputerSystem class Microsoft.Management.Infrastructure.CimException:
Não encontrado
[ERR] Agent authentication failed
[{"ErrorCode":"NotEmptyValidator","ErrorMessage":"'Machine Id' must not be
empty.","PropertyName":"MachineId","$type":"ApiError"},{"ErrorCode":"NotEmptyVali
dator","ErrorMessage":"'OS' must not be
empty.","PropertyName":"OS","$type":"ApiError"},{"ErrorCode":"LengthValidator","Err
orMessage":"'OS' must be between 1 and 255 characters. You entered 0
characters.","PropertyName":"OS","$type":"ApiError"}
Esta falla está relacionada con el servicio WMI de Windows, utilizado por DCA and Cloud Connector para recopilar información del sistema y de los dispositivos.
Solución
Aplique el procedimiento según la causa identificada.
Causa 1 (falla al insertar la clave del cliente)
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Desinstale el agente DCA and Cloud Connector del ordenador, tal y como se indica en Eliminar el agente en Windows
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Instale el agente DCA and Cloud Connector de nuevo, asegurándose de que la clave del cliente se introduce correctamente, tal y como se indica en Instalar el agente en Windows
Causa 2 (falla de clase no válida) o 3 (falla de autenticación del agente)
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Por precaución, detenga el servicio DCA and Cloud Connector en Windows:
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Abra el Administrador de servicios como administrador (Win + R → introduzca services.msc → OK)
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Busque y detenga el servicio NDD - DCA and Cloud Connector
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Restaure winmgmt:
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Abra Windows PowerShell como administrador
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Ejecute el comando
winmgmt /resetrepository
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Si no devuelve ningún error:
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Ejecute el comando
(Get-CimInstance -ClassName Win32_ComputerSystemProduct).UUID -
Si se devuelve el GUID, inicie el servicio DCA and Cloud Connector en Windows:
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Abra el Administrador de servicios como administrador (Win + R → introduzca services.msc → OK)
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Busque y arranque el servicio NDD - DCA and Cloud Connector
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En el portal NDD Orbix, compruebe que el servicio NDD - DCA and Cloud Connector aparece y tiene el Estado Online, tal y como se indica en Ver informaciones de los servicios
Si aparece el mensaje “Imposible ejecutar, ya que hay servicios o procesos en ejecución que dependen de él”:
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Ejecute el comando
Get-Service -Name winmgmt | Select-Object -ExpandProperty DependentServicespara enumerar los servicios que se están ejecutando y que dependen directamente de winmgmt
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Detenga todos los servicios con el estado Running:
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Ejecute el comando
sc.exe stop <serviceName>, sustituyendo<serviceName>por el nombre del servicio
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Ejemplo
sc.exe stop vmns
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Después de detener todos los servicios, ejecute el comando
winmgmt /resetrepository -
Inicie el servicio DCA and Cloud Connector en Windows:
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Abra el Administrador de servicios como administrador (Win + R → introduzca services.msc → OK)
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Busque y arranque el servicio NDD - DCA and Cloud Connector
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En el portal NDD Orbix, compruebe que el servicio NDD - DCA and Cloud Connector aparece y tiene el Estado Online, tal y como se indica en Ver informaciones de los servicios
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Reinicie todos los servicios que se detuvieron en el paso 2:
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Ejecute el comando
sc.exe start <serviceName>, sustituyendo<serviceName>por el nombre del servicio
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Ejemplo
sc.exe start vmns