Error updating the computer's location

Failure

An error occurred while updating the computer's location, and the geolocation has not been updated.

Cause

This failure can occur for various reasons, such as:

  1. The computer has been inactive and has not sent data to the portal for more than 7 days.

  2. Windows location services are disabled.

  3. No Wi-Fi adapter is available.

  4. Wi-Fi is disabled, or no nearby networks were found.

  5. Wi-Fi network information could not be collected.

  6. Google was unable to determine the location using the available networks.

  7. Google geolocation is disabled for this environment.

  8. A highly accurate location could not be obtained. The location displayed is approximate.

  9. The device’s location could not be determined.

  10. The approximate location could not be determined using the public IP address.

Solution

Identify the cause and apply the corresponding solution:

1. The computer has been inactive and has not sent data to the portal for more than 7 days.

Check the status of the NDD - Computer Monitor service.

If the service is stopped or has an offline status, the computer is inactive due to a lack of communication between the DCA agent, Cloud Connector, and the NDD Orbix portal.

Perform remote actions (start or restart) on the service to reestablish communication.

Wait a few moments and check if the computer is active again.

If the service remains stopped or has an offline status and/or the computer remains inactive, we recommend opening a support ticket to get help resolving the issue.

2. Windows location services are disabled.

Enable location services in Windows, as instructed below at Enable computer location in Windows.

3. No Wi-Fi adapter is available.

Confirm that your computer has a Wi-Fi adapter installed and working properly.

  1. In Windows, access Device Manager

  2. Check that the Network adapters section is enabled and shows no errors

4. Wi-Fi is disabled, or no nearby networks were found.
  1. Turn off airplane mode on your computer

  2. Enable Wi-Fi

You don’t need to connect your computer to a Wi-Fi network, but nearby networks must be available.

5. Wi-Fi network information could not be collected.
  1. Restart your computer

  2. Check that Wi-Fi is working normally

If the failure persists, ask your company’s IT team to check the drivers and the Automatic WLAN Configuration service.

6. Google was unable to determine the location using the available networks.
  1. Enable Wi-Fi

  2. Wait a few minutes

  3. Try updating your location again

If possible, perform the test in a location with a greater quantity of nearby Wi-Fi networks.

7. Google geolocation is disabled for this environment.

NDD Orbix functionality must be enabled in the environment.

Request enablement from the environment administrator or contact NDD support.

8. A highly accurate location could not be obtained. The location displayed is approximate.
  1. Keep Wi-Fi enabled

  2. Keep location services enabled

  3. Try updating your location again

The displayed location may remain approximate, depending on the information available in the environment.

9. The device’s location could not be determined.
  1. Check your internet connection

  2. Check that Wi-Fi is enabled

  3. Turn off airplane mode on your computer

  4. Enable location services in Windows, as instructed below at Enable computer location in Windows

  5. Restart the corresponding NDD - Computer Monitor service, as instructed at Start, stop or restart service

  6. Try updating your location again

10. The approximate location could not be determined using the public IP address.
  1. Check your internet connection

  2. Check whether using a VPN or proxy is affecting the consistency of your public IP address

If necessary, contact your company’s IT team to verify your network configurations.

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